Articles

Améliorer les performances de la fonction RECHERCHEV Excel

Ou comment améliorer les performances de la fonction RECHERCHEV… De façon spectaculaire !

Sur quelques articles de ce site, nous avons évoqué les performances poussives de la fonction RECHERCHEV, lorsqu’elle est utilisée en mode recherche exacte (dernier paramètre à VRAI). Dommage pour la fonction la plus utile du

Pourtant, la solution pour accélérer radicalement cette fonction est vraiment simple. Tellement simple qu’on se demande bien comment diable cette correction n’est pas implémentée directement dans Excel

Il suffit juste de travailler avec cette même fonction RECHERCHEV en recherche approximative, et tester si la valeur retournée est égale à la valeur cherchée. Si nous effectuons la recherche suivante :

=RECHERCHEV(B2;clients!$A$1:$C$10001;3;FAUX)

Nous cherchons la 3ème colonne de la correspondance exacte de B2. Nous pouvons écrire très simplement :

=SI(RECHERCHEV(B2;clients!$A$1:$C$10001;1;VRAI)<>B2;NA();RECHERCHEV(B2;clients!$A$1:$C$10001;3;VRAI))

Attention, les données cibles doivent être triées !

Ce qui revient à faire une recherche approximative (qui est 50 fois plus rapide…), tester la valeur retournée, et si elle est différence, forcer le résultat à #N/A. Si elle est égale, nous renvoyons la 3ème colonne.

Simplissime, et pour les tableaux « monstrueux » à plusieurs centaines de milliers de lignes, le résultat sera sans appel. Dans un cas avec 500.000 lignes, on est passé de 14s à 1s.

La fonction RECHERCHE est lente ? Plus maintenant !

Top

1 Comment


Laisser un commentaire

Required fields are marked *.


 

Top

Contactez-nous contact@expert-data.fr

EXPERT data, solutions pour TPE/PME et grands comptes